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Photoshop CS Productivity – Part 2 

Actions, Droplets, and Scripts Automate a Process 
 

Actions: a set of Photoshop steps executed automatically within Photoshop 
-- Actions allow you to automate procedures in Photoshop that you perform many times. 
 

Actions are used in Photoshop, 
Ø to perform a specific procedure using the Action palette 
Ø to perform the same specific procedure on one or multiple files using the File > Automate > 

Batch command 
 

Photoshop CS’s Action Sets are normally stored at C:\Program Files\Photoshop CS\Presets\ 
Photoshop Actions 

 
Definitions  
Ø Action Set: a group of Actions (e.g., Dan.atn) 
Ø Action: a defined set of Commands 

   (e.g., Sharpen in Lab Mode) 
Ø Command: one step of an Action, often with 

  parameters (e.g., Stop, Convert Mode, etc) 
 
Actions Palette Columns (left to right) 
Ø Check Box: execute or ignore item to right 
Ø Dialog Box: item to right contains a Dialog 

  Box causing Action to pause 
Ø Item: the name of the Action Set, Action, 

or Command 
 

Actions Palette Buttons  (on bottom, left to right) 
Ø Stop (or Esc): stop the recording or playing of an Action sequence; press the Play button to 

resume recording or playing the Action 
Ø Record: start recording the Action sequence 
Ø Play  

o When an Action Set is selected: play all Actions within the Action Set 
o When an Action is selected: play the Action from its beginning 
o When an Command is selected: play the Actions starting at this Command  

Ø New Set: create a new Action Set 
Ø New Action: create a new Action 
Ø Trash: delete the selected Action or Command 

 
Actions Palette Menu Items (the ?  button at top-right) 

Ø Button Mode : toggle between a detailed palette or a Action Name-only palette 
Ø Insert Menu Item: add commands such as most Photoshop’s pull-down commands (e.g., File > 

Open) and non-recordable commands (e.g., File > Import, File > Info) 
Ø Insert Stop: insert a text prompt up to 255 characters to give a title or provide instruction 
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o Allow Continue : determine what button options are available with the Insert Stop 
§ If reset, provide one button: Stop to allow a process to be executed manually 
§ If set, provide two buttons : Continue to continue with the Action if the Stop just 

provides information and Stop to allow a process to be executed manually 
Ø Reset Actions : delete all Action Sets and load the default Action Set 
Ø Load Actions : add the selected Action Set  
Ø Replace Actions : delete all Action Sets and load a new Action Set 
Ø Save Actions : save the selected Action Set 
Ø Save Actions but hold mouse down, ctrl+alt, release mouse: save all Action Sets as a text file 

for documentation purposes 
Ø Library Files (the List at the bottom of Menu) : click on an Action Set to add to the current set 

o Actions stored at Photoshop CS\Presets\Photoshop Actions appear on this list 
 
1. To load an Action Set supplied with Photoshop CS 

a. Actions palette menu: Load Actions  
b. Select folder C:\Program Files\Photoshop CS\Presets\Photoshop Actions 
c. Select the desired Action Set 

 
2. Create a new Action Set 

a. Actions Palette: press the Create New Set button 
i. Set = Test (or any name) 

I name my personal Action Set Dan so that I can easily identify it when I need to find it later. 
 

3. Create an Action activated by a Shortcut to configure the File Browser 
This Action automates the Workspace configurations defined in part 1 of the Productivity 
discussion. 

a. Actions palette: press the Create New Action button  
i. Action = “Browser – Thumbnails” 

ii. Set = Test.atn 
iii. Function Key = F10, Control 
iv. Press the Record button 

b. Photoshop: Window > Workspace > “File Browser – Thumbnails” 
c. Press the keyboard’s Escape key to terminate Action recording 

 
4. Use these Actions to configure the File Browser 

These are the shortcuts for the 3 Actions I created for the 3 File Browser configurations. 
a. Ctrl+F9 for the Standard File Browser configuration 
b. Ctrl+F10 for the Thumbnail File Browser configuration 
c. Ctrl+F11 for the Preview File Browser configuration 

 
5. Create an Action to reduce the selected Image’s Size to a maximum of 800 pixels for use as 

an e-mail attachment or in a Slide Show 
a. Open a multi- layer image 
b. Actions palette: press the Create New Action button  

i. Name = “Limit to 800 pixels” 
ii. Set = Test.atn 
iii. Press the Record button 

c. Layers Palette menu > Flatten Image 
d. File > Automate > Fit Image, Height = 800 pixels, Width = 800 pixels 
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e. Action palette > Menu > Insert Stop  
i. Message = “Remember to Save with a * net.jpg file name.” 

ii. Allow Continue = checked 
f. Actions palette = click the Stop button (left-most square) 

 
This type of Action would be handy to convert images for camera club competition by limiting the 
Fit Image to 768px by 1024 px and changing the Color Mode to sRGB. 

 
6. Use this Action to Reduce the selected Image’s Size for use as an E-mail attachment 

a. Open an image 
b. Action palette: select Set = Test.atn, Action = “Limit to 800 pixels” 
c. Action palette: Press the Play button 
d. Read the Message prompt and press Continue   
e. Photoshop: Save As > {new file name}  

 
For e-mail purposes, I would save the reduced version of Flowers.jpg as Flowers net.jpg. 

 
7. Use this Action  to create a Slide Show using Reduced Resolution Images 

If not reduced in size, Photoshop’s PDF slide show program uses full resolution images and 
creates a huge slide show file. 

a. Copy all image files to be included in the Slide Show to a separate folder 
b. Actions palette: select Set = Test.atn, Action = “Limit to 800 pixels”, uncheck the box 

next to the Stop command to avoid stopping the Action during Batch operation 
c. File Browser: select the images for the Slide Show: Automate > Batch >  

i. Action palette: select Set = Test.atn, Action = “Limit to 800 pixels” 
ii. Source = Folder, Choose = folder containing the files 
iii. Destination = Folder, Choose = folder to contain the new files 
iv. File Naming = Document Name | _800px | extension 

d. File Browser: Arrange reduced resolution images in desired slide show order; ctrl+A to 
select all images 

e. File Browser: Automate > PDF Presentation 
i. Save As: Presentation 

ii. View Presentation 
f. View the Slide Show; press Ecape to quit 
g. When done, delete the reduced resolution files if desired 

 
8. Create an Action to sharpen a Photoshop image in LAB mode 

a. File > Open > {any multi- layer image} 
b. Actions palette: New Action icon > Name = “Sharpen in LAB mode”, press Record 
c. Actions palette menu > Insert Stop  

i. Message = “Perform image sharpening in LAB” 
ii. Allow Continue = checked 

d. Layer > Flatten Image 
e. Image > Mode > Lab Color 
f. Channels palette > select L channel 
g. Actions palette menu: Insert Stop  

i. Message = “Execute Unsharp Filter  
ii. Sharpen > Unsharp Filter   
iii. Action palette: click on Play button when finished.” 



5/17/2005 Channel City Camera Club Page 4 

h. Image > Mode > RGB Color 
i. Actions palette = click on the Stop button  

 
9. Use the Action to sharpen a Photoshop image in LAB mode 

a. File Browser: select a Photoshop *.psd image to be sharpened and open in Photoshop 
b. Actions palette: select the Action, Sharpen in LAB; click on the Play button  
c. Read the Message prompt and press Continue   
d. Flatten image if n eeds to be flattened 
e. Read the second Message prompt and press Stop (note: image is now in LAB mode with 

the L-channel selected) 
f. Photoshop: Filter > Sharpen > Unsharp Mask > set sharpening parameters 
g. Actions palette: click on the Play button (triangle) to continue the Action 
h. Photoshop: Save As > {file name} 

 
10. To Add a new Command to an Action 

a. Select existing command before new entry 
b. Press the Record button  
c. Execute the Photoshop commands to be added 
d. Press the Stop button 

 
To add a new first command, add this command after the current first command and then move 
the commands into the proper sequence. 
 

11. To Delete a bad Command from an Action while Recording 
a. Press the Stop button 
b. Delete the bad command 
c. Press the Record button to continue the recording process 

 
12. Use the Action to create a jig-saw puzzle of an image 

This Action can be found at the Adobe Studio Exchange, http://share.studio.adobe.com/. On the 
left under Find, enter What = “puzzle effects” and Where = “Photoshop Files”. To install after 
downloading and unzipping, open the Actions palette menu, select Load Action and select the 
downloaded Action Set. 

a. File Browser: File > Open > select a flattened image to be converted into a jig-saw 
b. Set the Foreground Color for a background for the puzzle 
c. Action palette: select Set = PUZZLE EFFECTS.atn, Action = “Jigsaw – 30 pieces” 
d. Action palette: Press the Play button 
e. Read the Message prompt and press Continue  
f. Read the second Message prompt and press Continue  
g. Adjust the Layer Style parameters to produce a nice bevel; press OK 
h. When done, read the third Message prompt and press Stop 
i. Layers palette: select the layer of a puzzle piece to move,  alt+click the Link box to unlink 

from the other layers 
j. Move tool: move individual puzzle pieces 
k. Photoshop: Save As > {new file name} 

 
For more Actions, do a Google search on Photoshop Actions or visit the Adobe Studio Exchange at, 
http://share.studio.adobe.com/ and click on Actions at the Adobe Photoshop pull-down. 
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Droplets: a set of Photoshop steps run outside of Photoshop 
-- A Droplet is an executable program similar in purpose to the use of Automate > Batch that builds-in 
and fixes the Batch destination and file naming parameters.  
-- A Droplet may be easier to use than entering the Batch parameters each time it is used but it is limited 
to these pre-defined parameters. 
 

To convert an Action into a Droplet, File > Automate > Create Droplet  
 
The Photoshop CS Droplets are normally stored at C:\Program Files\Photoshop CS\Samples\ 
Droplets\Photoshop Droplets 

 
Droplets are used, 
Ø Outside of Photoshop to perform the same specific procedure on one or multiple files using a 

fixed set of parameters as found in the Batch command 
Ø By dragging image files or folders from Windows Explorer to the Droplet icon on the Desktop 

or to the Droplet file in a folder 
 

13. Convert the Reduce Resolution Action into a Droplet 
a. File > Automate > Create Droplet > 

i. Save Droplet in = Desktop 
ii. Play: Set = Test.atn, Action = “Limit to 800 pixels 
iii. Destination = Save & Close 

b. Rename the Action, “800 px limit.exe” 
 

14. Convert a folder of image files using this Droplet  
a. Display Desktop 
b. Explorer: drag files to the Droplet, “800 px limit.exe” 
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Scripts: Advanced Procedures 
-- Scripts are procedures written in Visual Basic (PC), AppleScript (Mac), or JavaScript (PC and Mac) 
that achieve results far beyond the capability of Actions.  
-- A Script may contain conditional logic, looping, Boolean operations, comparisons, and complex math. 
Programming skills are required to create Scripts.  
-- Photoshop contains documentation on all three languages in Photoshop CS \ Scripting Guide. 
 
Example: a Script could be written to determine the image resolution and then apply a filter with 
parameters appropriate for that specific resolution. 
 

Scripts are executed at File > Scripts. 
 
In Photoshop CS, Scripts are normally stored at Program Files\Photoshop CS\Presets\Scripts. 

 
15. Run a script provided with Photoshop CS to save each layer as a separate file 

a. Open an image with multiple layers 
b. File > Scripts > Export Layers to Files 

 
For more scripts, do a Google search on Photoshop Scripts or visit the Adobe Studio Exchange at, 
http://share.studio.adobe.com/ and click on Scripts at the Adobe Photoshop pull-down. 
 

Final notes 
Ø If you upgrade Photoshop, be sure to copy your personal Actions, Droplets, and Scripts to the 

folders of the upgraded Photoshop. 
Ø If you want more information about Actions, Droplets, and Scripts, check out, “Photoshop 

Actions – the Mother of All Tutorials” at http://www.atncentral.com/tutorials.htm. 
 

 
_____________________________________________________________________________________ 
Dan Moore 
 


